Click or drag to resize

RhinoMathCRC32 Method (UInt32, Byte)

Advances the cyclic redundancy check value remainder given a byte array. http://en.wikipedia.org/wiki/Cyclic_redundancy_check.

Namespace:  Rhino
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static uint CRC32(
	uint currentRemainder,
	byte[] buffer
)

Parameters

currentRemainder
Type: SystemUInt32
The remainder from which to start.
buffer
Type: SystemByte
The value to add to the current remainder.

Return Value

Type: UInt32
The new current remainder.
See Also