Click or drag to resize

ChangeQueue Methods

The ChangeQueue type exposes the following members.

Methods
  NameDescription
Protected methodApplyClippingPlaneChanges
Override this when you want to handle clippingplane changes
Protected methodApplyDisplayPipelineAttributesChanges
Override if you need to react to display attribute changes. This function is needed to be able to react to different sample settings for i.e. capture preview rendering.
Protected methodApplyDynamicClippingPlaneChanges
Override this when you want to handle dynamicclippingplane changes
Protected methodApplyDynamicLightChanges
Handle dynamic light changes
Protected methodApplyDynamicObjectTransforms
Handle dynamic object transforms
Protected methodApplyEnvironmentChanges
Override this when you want to handle environment changes
Protected methodApplyGroundPlaneChanges
Override this when you want to handle groundplane changes
Protected methodApplyLightChanges
Override this when you want to handle light changes
Protected methodApplyLinearWorkflowChanges
Override this when you want to handle linear workflow changes
Protected methodApplyMaterialChanges
Override when you want to handle material changes
Protected methodApplyMeshChanges
Override this when you want to handle mesh changes.
Protected methodApplyMeshInstanceChanges
Override this when you want to handle mesh instance changes (block instances and first-time added new meshes)
Protected methodApplyRenderSettingsChanges(DisplayRenderSettings)
Override this when you want to handle render setting changes. These are for the viewport settings.
Protected methodApplyRenderSettingsChanges(RenderSettings)
Override this when you need to handle background changes (through RenderSettings)
Protected methodApplySkylightChanges
Override this when you want to handle skylight changes
Protected methodApplySunChanges
Override this when you want to handle sun changes
Protected methodApplyViewChange
Override ApplyViewChange when you want to receive changes to the view/camera
Public methodAreViewsEqual
Compare to ViewInfo instances and decide whether they are equal or not. If you need to change the way the comparison is done you can override this function and implement your custom comparison.
Protected methodBakeFor
Override this if you need to control baking behavior for textures. By default bake everything.
Protected methodBakingSize
Override this if you need to control the size of the baked bitmaps for textures. By default the value returned is 2048.
Protected methodContentRenderHash
Override this if you need to modify the way render hashes are calcuated in the change queue. This will alter the way materials are grouped.
Public methodStatic memberConvertCameraBasedLightToWorld
Convert given (camera-based) light to a world-based light (in-place)
Public methodStatic memberCrcFromGuid
Helper function to get a CRC from a Guid.
Public methodCreateWorld
Calls CreateWorld with true passed.
Public methodCreateWorld(Boolean)
Signal the queue to do the initialisation of the queue, seeding it with the content currently available.
Public methodDispose
Dispose our ChangeQueue
Protected methodDispose(Boolean)
Dispose our ChangeQueue. Disposes unmanaged memory.
Public methodEnvironmentForid
Get RenderEnvironment for given RenderHash. Can return null.
Public methodEnvironmentFromOriginalInstanceId
Get the RenderEnvironment from the ChangeQueue content cache from the original instance id
Public methodEnvironmentIdForUsage
Get RenderEnvironment RenderHash for given usage.
Public methodFlush
Tell the ChangeQueue to flush all collected events. This can trigger a host of Apply* calls. The following is the order in which those calls get made if there are changes for that specific data type: ApplyViewChange ApplyLinearWorkflowChanges ApplyDynamicObjectTransforms ApplyDynamicLightChanges ApplyRenderSettingsChanges ApplyEnvironmentChanges (background) ApplyEnvironmentChanges (refl) ApplyEnvironmentChanges (sky) ApplySkylightChanges ApplySunChanges ApplyLightChanges ApplyMaterialChanges ApplyMeshChanges ApplyMeshInstanceChanges ApplyGroundPlaneChanges ApplyClippingPlaneChanges
Public methodGetQueueGroundPlane
Get groundplane known to the queue at the time of the Flush
Public methodGetQueueRenderSettings
Get render settings known to the queue at the time of the Flush
Public methodGetQueueSceneBoundingBox
Get the scene bounding box
Public methodGetQueueSkylight
Get skylight known to the queue at the time of the Flush
Public methodGetQueueSun
Get sun known to the queue at the time of the Flush
Public methodGetQueueView
Get view known to the queue at the time of the Flush
Public methodMaterialFromId
Get the RenderMaterial from the ChangeQueue material cache based on RenderHash
Public methodMaterialFromOriginalInstanceId
Get the RenderMaterial from the ChangeQueue material cache from the original instance id
Protected methodNotifyBeginUpdates
Override this when you want to be notified of begin of changes
Protected methodNotifyDynamicUpdatesAreAvailable
Override this when you want to be notified dynamic updates are available
Protected methodNotifyEndUpdates
Override this when you want to be notified when change notifications have ended.
Public methodOneShot
Call Flush() once, after that automatically dispose the queue.
Protected methodProvideOriginalObject
Override ProvideOriginalObject and return true if you want original objects supplied with ChangeQueue.Mesh. This will then also allow access to the Attributes.UserData of the original object from which the Mesh was generated.
Public methodTextureForId
Get RenderTexture for given RenderHash. Can return null.
Public methodTextureFromOriginalInstanceId
Get the RenderTexture from the ChangeQueue content cache from the original instance id
Top
See Also