RhinoCommon API
RhinoCommon API
Namespaces
Rhino.Render.ChangeQueue
ChangeQueue Class
ChangeQueue Methods
ApplyClippingPlaneChanges Method
ApplyDisplayPipelineAttributesChanges Method
ApplyDynamicClippingPlaneChanges Method
ApplyDynamicLightChanges Method
ApplyDynamicObjectTransforms Method
ApplyEnvironmentChanges Method
ApplyGroundPlaneChanges Method
ApplyLightChanges Method
ApplyLinearWorkflowChanges Method
ApplyMaterialChanges Method
ApplyMeshChanges Method
ApplyMeshInstanceChanges Method
ApplyRenderSettingsChanges Method
ApplySkylightChanges Method
ApplySunChanges Method
ApplyViewChange Method
AreViewsEqual Method
BakeFor Method
BakingSize Method
ContentRenderHash Method
ConvertCameraBasedLightToWorld Method
CrcFromGuid Method
CreateWorld Method
Dispose Method
EnvironmentForid Method
EnvironmentFromOriginalInstanceId Method
EnvironmentIdForUsage Method
Flush Method
GetQueueGroundPlane Method
GetQueueRenderSettings Method
GetQueueSceneBoundingBox Method
GetQueueSkylight Method
GetQueueSun Method
GetQueueView Method
MaterialFromId Method
MaterialFromOriginalInstanceId Method
NotifyBeginUpdates Method
NotifyDynamicUpdatesAreAvailable Method
NotifyEndUpdates Method
OneShot Method
ProvideOriginalObject Method
TextureForId Method
TextureFromOriginalInstanceId Method
ChangeQueue
OneShot Method
Call Flush() once, after that automatically dispose the queue.
Namespace:
Rhino.Render.ChangeQueue
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since:
6.0
Syntax
C#
VB
Copy
public
void
OneShot
()
Public
Sub
OneShot
See Also
Reference
ChangeQueue Class
Rhino.Render.ChangeQueue Namespace
Rhino 8.13.24317.13000 (2024-11-12)
Copyright © 2009-2024 Robert McNeel & Associates
Report wishes and bugs at discourse.mcneel.com