Click or drag to resize

BrepFaceList Methods

The BrepFaceList type exposes the following members.

Methods
  NameDescription
Public methodAdd(Int32)
Create and add a new face to this list. An incomplete face is added. The caller must create and fill in the loops used by the face.
Public methodAdd(Surface)
Add a new face to a brep. This creates a complete face with new vertices at the surface corners, new edges along the surface boundary, etc. The loop of the returned face has four trims that correspond to the south, east, north, and west side of the surface in that order. If you use this version of Add to add an exiting brep, then you are responsible for using a tool like JoinEdges() to hook the new face to its neighbors.
Public methodAddConeFace
Add a new face to the brep whose surface geometry is a ruled cone with the edge as the base and the vertex as the apex point.
Public methodAddRuledFace
Add a new face to the brep whose surface geometry is a ruled surface between two edges.
Public methodExtractFace
Extracts a face from a Brep.
Public methodFlip
Flips the orientation of faces.
Public methodGetEnumerator
Gets an enumerators that yields BrepFace objects.
Public methodRemoveAt
Deletes a face at a specified index.
Public methodRemoveSlits
Remove slit trims and slit boundaries from each face.
Public methodShrinkFaces
Shrinks all the underlying surfaces in this Brep. Sometimes the surfaces extend far beyond the trimming boundaries of the Brep Face. This function will remove those portions of the surfaces that are not used.
Public methodSplitBipolarFaces
Splits surfaces with two singularities, like spheres, so the results have at most one singularity.
Public methodSplitClosedFaces
Splits closed surfaces so they are not closed.
Public methodSplitFaceAtTangents
Splits the face of a Brep at tangent locations.
Public methodSplitFacesAtTangents
Splits all of the faces of a Brep at tangent locations.
Public methodSplitKinkyFace
Splits a single face into G1 pieces.
Public methodSplitKinkyFaces
Splits any faces with creases into G1 pieces.
Public methodSplitKinkyFaces(Double)
Splits any faces with creases into G1 pieces.
Public methodSplitKinkyFaces(Double, Boolean)
Splits any faces with creases into G1 pieces.
Public methodStandardizeFaceSurface
Standardizes the relationship between a BrepFace and the 3d surface it uses. When done, the face will be the only face that references its 3d surface, and the orientations of the face and 3d surface will be the same.
Public methodStandardizeFaceSurfaces
Standardize all faces in the brep.
Top
See Also