BrepFaceListSplitKinkyFaces Method (Double) |
Splits any faces with creases into G1 pieces.
Namespace:
Rhino.Geometry.Collections
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public bool SplitKinkyFaces(
double kinkTolerance
)
Public Function SplitKinkyFaces (
kinkTolerance As Double
) As Boolean
Parameters
- kinkTolerance
- Type: SystemDouble
Tolerance (in radians) to use for crease detection.
Return Value
Type:
Booleantrue on success, false on failure.
Remarks If you need to detect whether splitting occurred,
compare the before and after values of Faces.Count
See Also