Click or drag to resize

LightTable Methods

The LightTable type exposes the following members.

Methods
  NameDescription
Public methodAdd(Light)
Public methodAdd(Light, ObjectAttributes)
Public methodDelete(LightObject) (Overrides CommonComponentTableTDelete(T).)
Public methodDelete(Int32, Boolean)
Public methodFind
Public methodFindIndex
Retrieves a object based on Index. This search type of search is discouraged. We are moving towards using only IDs for all tables.
Public methodFindName
Finds the LightObject with a given name.

Deleted lights have no name.

Public methodFindNameHash
Finds a LightObject given its name hash.
Public methodGetEnumerator (Overrides CommonComponentTableTGetEnumerator.)
Public methodCode exampleModify(Guid, Light)
Public methodModify(Int32, Light)
Public methodUndelete
Restores a light that has been deleted.
Top
See Also