Click or drag to resize

ObjectAttributes Methods

The ObjectAttributes type exposes the following members.

Methods
  NameDescription
Public methodAddHideInDetailOverride
Make this object hidden in a given detail
Public methodAddToGroup
Adds object to the group with specified index by appending index to group list.

If the object is already in group, nothing is changed.

Public methodComputedPlotColor(RhinoDoc)
Public methodComputedPlotColor(RhinoDoc, Guid)
Public methodComputedPlotWeight(RhinoDoc)
Public methodComputedPlotWeight(RhinoDoc, Guid)
Public methodDeleteAllUserStrings
Public methodDeleteUserString
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.
Public methodDrawColor(RhinoDoc)
Gets an object's draw color, which is based on the object's color source
Public methodDrawColor(RhinoDoc, Guid)
Gets an object's draw color, which is based on the object's color source
Public methodDuplicate
Constructs a copy of this ObjectAttributes instance.
Public methodGetCustomLinetype
Get an optional custom linetype associated with these attributes. If null, then the attributes use the linetype index to determine it's linetype
Public methodGetCustomSectionStyle
Get an optional custom section style associated with these attributes.
Public methodGetDisplayModeOverride
Returns the id of the display mode of an objects. Object display modes are view based. Thus, it is possible to have an object display different in different views.
Public methodGetGroupList
Returns an array of GroupCount group indices. If GroupCount is zero, then GetGroupList() returns null.
Public methodGetHideInDetailOverrides
Get list of details that this object is supposed to be hidden in
Public methodGetUserString
Gets a user string.
Public methodGetUserStrings
Gets an independent copy of the collection of (user text key, user text value) pairs attached to this object.
Public methodCode exampleHasDisplayModeOverride
Determines if an object has a display mode override for a given viewport.
Public methodHasHideInDetailOverrideSet
Is this object supposed to be hidden in a given detail
Public methodIsInGroup
Determines if an object belong to a group or not.
Public methodObjectFrame
Public methodRemoveCustomLinetype
Public methodRemoveCustomSectionStyle
Public methodRemoveDisplayModeOverride
By default, objects are drawn using the display mode of the viewport that the object is being drawn in. Setting a specific display mode, instructs Rhino to always use that display mode, regardless of the viewport's mode. This function resets an object to use the viewport's display mode for all viewports.
Public methodCode exampleRemoveDisplayModeOverride(Guid)
By default, objects are drawn using the display mode of the viewport that the object is being drawn in. Setting a specific display mode, instructs Rhino to always use that display mode, regardless of the viewport's mode. This function resets an object to use the viewport's display mode.
Public methodRemoveFromAllGroups
Removes object from all groups.
Public methodRemoveFromGroup
removes object from the group with specified index.

If the object is not in the group, nothing is changed.

Public methodRemoveHideInDetailOverride
Remove hidden in detail flag for a specific detail
Public methodSetCustomLinetype
Public methodSetCustomSectionStyle
Public methodSetDisplayModeOverride(DisplayModeDescription)
By default, objects are drawn using the display mode of the viewport that the object is being drawn in. Setting a specific display mode, instructs Rhino to always use that display mode, regardless of the viewport's mode. This version affects the object's display mode for all viewports.
Public methodCode exampleSetDisplayModeOverride(DisplayModeDescription, Guid)
By default, objects are drawn using the display mode of the viewport that the object is being drawn in. Setting a specific display mode, instructs Rhino to always use that display mode, regardless of the viewport's mode. This version sets a display mode for a specific viewport.
Public methodSetObjectFrame(Plane)
Public methodSetObjectFrame(Transform)
Public methodSetUserString
Attach a user string (key,value combination) to this geometry.
Public methodTransform
Apply a transformation.
Top
See Also