Click or drag to resize

HistoryRecord Methods

The HistoryRecord type exposes the following members.

Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.

Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodSetBool
Public methodSetBools
Public methodSetBrep
Public methodSetColor
Public methodSetColors
Public methodSetCurve
Public methodSetDouble
Public methodSetDoubles
Public methodSetGuid
Public methodSetGuids
Public methodSetHistoryVersion
Specifies a non-zero integer that identifies the version of this history record. The virtual ReplayHistory() functions can check this version to avoid replaying history using information created by earlier versions of the command.
Public methodSetInt
Public methodSetInts
Public methodSetMesh
Public methodSetObjRef
Public methodSetPoint3d
Public methodSetPoint3dOnObject
Public methodSetPoint3ds
Public methodSetString
Public methodSetStrings
Public methodSetSurface
Public methodSetTransorm
Public methodSetVector3d
Public methodSetVector3ds
Top
See Also