Click or drag to resize

Command Methods

The Command type exposes the following members.

Methods
  NameDescription
Public methodStatic memberDisplayHelp
Displays help for a command.
Public methodStatic memberGetCommandNames
Gets list of command names in Rhino. This list does not include Test, Alpha, or System commands.
Public methodStatic memberGetCommandStack
Determines if Rhino is currently running a command. Because Rhino allow for transparent commands (commands that can be run from inside of other commands), this method returns the total ids of active commands.
Public methodStatic memberGetMostRecentCommands
Gets an array of most recent command descriptions.
Public methodStatic memberInCommand
Determines if Rhino is currently running a command.
Public methodStatic memberInScriptRunnerCommand
This is a low level tool to determine if Rhino is currently running a script running command like "ReadCommandFile" or the RhinoScript plug-in's "RunScript".
Public methodStatic memberIsCommand
Determines is a string is a command.
Public methodStatic memberIsValidCommandName
Determines if a string is a valid command name.
Public methodStatic memberLookupCommandId
Returns the ID of a command.
Public methodStatic memberLookupCommandName
Returns the command name given a command ID.
Protected methodOnHelp
Is called when the user needs assistance with this command.
Protected methodReplayHistory
Repeats an operation of a command.

In order to make this function work, you will likely need to grab the Result property that gives the list of input objects. Then, you will be able to replace these inputs by using one of the UpdateToX() methods of the ReplayHistoryResult.

You should NOT use any document AddX() or ReplaceX() functions, as they will break history.

Protected methodRunCommand
Executes the command.
Public methodStatic memberRunProxyCommand
Execute some code as if it were running in a command
Top
See Also