Click or drag to resize

CommandGetCommandNames Method

Gets list of command names in Rhino. This list does not include Test, Alpha, or System commands.

Namespace:  Rhino.Commands
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax
public static string[] GetCommandNames(
	bool english,
	bool loaded
)

Parameters

english
Type: SystemBoolean
if true, retrieve the English name for every command. if false, retrieve the local name for every command.
loaded
Type: SystemBoolean
if true, only get names of currently loaded commands. if false, get names of all registered (may not be currently loaded) commands.

Return Value

Type: String
An array instance with command names. This array could be empty, but not null.
See Also