Click or drag to resize

ShortcutKeySettings Methods

The ShortcutKeySettings type exposes the following members.

Methods
  NameDescription
Public methodStatic memberGetDefaults
Get all the default shortcuts registered with Rhino
Public methodStatic memberGetLabel
Get the macro label associated with a given keyboard shortcut
Public methodStatic memberGetMacro
Get macro associated with a given keyboard shortcut
Public methodStatic memberGetShortcuts
Get all shortcuts registered with Rhino
Public methodStatic memberIsAcceptableKeyCombo
Is a key plus modifier combination one that can be used with Rhino
Public methodStatic memberSetMacro(ShortcutKey, String)
Set macro associated with a keyboard shortcut
Public methodStatic memberSetMacro(KeyboardKey, ModifierKey, String)
Set a macro for a given key and modifier combination
Public methodStatic memberUpdate
Add or modify shortcuts with a list or KeyboardShortcut elements
Top
See Also