PythonScriptExecuteFile Method |
Executes a Python file. The file is executed in a new, __main__ scope.
Namespace:
Rhino.Runtime
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public abstract bool ExecuteFile(
string path
)
Public MustOverride Function ExecuteFile (
path As String
) As Boolean
Parameters
- path
- Type: SystemString
The path to the file.
Return Value
Type:
Booleantrue if the file executed. This method can throw scripting-runtime based exceptions.
See Also