Note: This API is now obsolete.
Blend color with the decal color at a given point.
Namespace:
Rhino.Render
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.10
Syntax [ObsoleteAttribute("Incredibly slow call")]
public bool TryGetColor(
Point3d point,
Vector3d normal,
ref Color4f colInOut,
ref Point2d uvOut
)
<ObsoleteAttribute("Incredibly slow call")>
Public Function TryGetColor (
point As Point3d,
normal As Vector3d,
ByRef colInOut As Color4f,
ByRef uvOut As Point2d
) As Boolean
Parameters
- point
- Type: Rhino.GeometryPoint3d
The point in space or, if the decal is uv-mapped, the uv-coordinate of that point. - normal
- Type: Rhino.GeometryVector3d
The face normal of the given point. - colInOut
- Type: Rhino.DisplayColor4f
The color to blend the decal color to. - uvOut
- Type: Rhino.GeometryPoint2d
the UV on the texture that the color point was read from.
Return Value
Type:
Booleantrue if the given point hits the decal, else false.
See Also