Click or drag to resize

Decal Methods

The Decal type exposes the following members.

Methods
  NameDescription
Public methodConstPointer
Public methodStatic memberCreate
Public methodCustomData
Gets decal custom data for the current renderer. See Rhino.Plugins.RenderPlugIn.ShowDecalProperties.
Public methodCustomData(Guid)
Gets decal custom data for a specified renderer. See Rhino.Plugins.RenderPlugIn.ShowDecalProperties.
Public methodDispose
Public methodDispose(Boolean)
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodGetTextureMapping
The TextureMapping of the decal.
Public methodHorzSweep
Gets the angles of the decal's arc of 'horizontal sweep'. Replaces StartLatitude and EndLatitude.
Public methodNonConstPointer
Public methodTextureRenderCRC(TextureRenderHashFlags) Obsolete.
This method is deprecated in favor of TextureRenderHash below.
Public methodTextureRenderCRC(TextureRenderHashFlags, LinearWorkflow) Obsolete.
This method is deprecated in favor of TextureRenderHash below.
Public methodTextureRenderHash(CrcRenderHashFlags) Obsolete.
Get the texture render hash for the referenced texture using the specified CrcRenderHashFlags.
Public methodTextureRenderHash(CrcRenderHashFlags, LinearWorkflow) Obsolete.
Get the texture render hash for the referenced texture using the specified CrcRenderHashFlags and linear workflow.
Public methodTryGetColor Obsolete.
Blend color with the decal color at a given point.
Public methodUVBounds
The UV bounds of the decal. Only used when mapping is UV.
Public methodVertSweep
Gets the angles of the decal's arc of 'vertical sweep'. Replaces StartLongitude and EndLongitude.
Top
See Also