IntersectionMeshPlane Method (Mesh, IEnumerablePlane) |
Intersects a mesh with a collection of infinite planes.
Namespace:
Rhino.Geometry.Intersect
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public static Polyline[] MeshPlane(
Mesh mesh,
IEnumerable<Plane> planes
)
Public Shared Function MeshPlane (
mesh As Mesh,
planes As IEnumerable(Of Plane)
) As Polyline()
Parameters
- mesh
- Type: Rhino.GeometryMesh
Mesh to intersect. - planes
- Type: System.Collections.GenericIEnumerablePlane
Planes to intersect with.
Return Value
Type:
Polyline
An array of polylines describing the intersection loops,
or null if no intersections could be found.
See Also