IntersectionMeshPlane Method (Mesh, Plane) |
Intersects a mesh with an infinite plane.
Namespace:
Rhino.Geometry.Intersect
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 5.0
Syntax public static Polyline[] MeshPlane(
Mesh mesh,
Plane plane
)
Public Shared Function MeshPlane (
mesh As Mesh,
plane As Plane
) As Polyline()
Parameters
- mesh
- Type: Rhino.GeometryMesh
Mesh to intersect. - plane
- Type: Rhino.GeometryPlane
Plane to intersect with.
Return Value
Type:
Polyline
An array of polylines describing the intersection loops,
or null if no intersections could be found.
See Also