Click or drag to resize

IntersectionMeshPlane Method (Mesh, MeshIntersectionCache, Plane, Double)

Intersects a mesh with an infinite plane.

Namespace:  Rhino.Geometry.Intersect
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 8.0
Syntax
public static Polyline[] MeshPlane(
	Mesh mesh,
	MeshIntersectionCache cache,
	Plane plane,
	double tolerance
)

Parameters

mesh
Type: Rhino.GeometryMesh
Mesh to intersect.
cache
Type: Rhino.Geometry.IntersectMeshIntersectionCache
Intersection cache for mesh.
plane
Type: Rhino.GeometryPlane
Plane to intersect with.
tolerance
Type: SystemDouble
Intersection tolerance.

Return Value

Type: Polyline
An array of polylines describing the intersection loops, or null if no intersections could be found.
See Also