Click or drag to resize

MeshIntersectionCache Class

Provides a mechanism for lazily evaluating mesh data.
Inheritance Hierarchy
SystemObject
  Rhino.Geometry.IntersectMeshIntersectionCache

Namespace:  Rhino.Geometry.Intersect
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 8.0
Syntax
public class MeshIntersectionCache : IDisposable

The MeshIntersectionCache type exposes the following members.

Constructors
  NameDescription
Public methodMeshIntersectionCache
Provides a mechanism for lazily evaluating mesh data. The implementation is private and subject to change.
Top
Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodDispose(Boolean)
Disposes the mesh intersection cache.
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Top
See Also