IntersectionMeshPlane Method (Mesh, MeshIntersectionCache, IEnumerablePlane, Double) |
Intersects a mesh with a collection of infinite planes.
Namespace:
Rhino.Geometry.Intersect
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 8.0
Syntax public static Polyline[] MeshPlane(
Mesh mesh,
MeshIntersectionCache cache,
IEnumerable<Plane> planes,
double tolerance
)
Public Shared Function MeshPlane (
mesh As Mesh,
cache As MeshIntersectionCache,
planes As IEnumerable(Of Plane),
tolerance As Double
) As Polyline()
Parameters
- mesh
- Type: Rhino.GeometryMesh
Mesh to intersect. - cache
- Type: Rhino.Geometry.IntersectMeshIntersectionCache
Intersection cache for the mesh. - planes
- Type: System.Collections.GenericIEnumerablePlane
Planes to intersect with. - tolerance
- Type: SystemDouble
Intersection tolerance.
Return Value
Type:
Polyline
An array of polylines describing the intersection loops,
or null if no intersections could be found.
See Also