ModelRenderMaterial Class |
Namespace: Grasshopper.Rhinoceros.Render
The ModelRenderMaterial type exposes the following members.
Name | Description | |
---|---|---|
![]() | ModelRenderMaterial() | Initializes a new instance of the ModelRenderMaterial class |
![]() | ModelRenderMaterial(ModelRenderMaterial.Attributes) | Initializes a new instance of the ModelRenderMaterial class |
![]() | ModelRenderMaterial(Guid) | Initializes a new instance of the ModelRenderMaterial class |
![]() | ModelRenderMaterial(Material) | Initializes a new instance of the ModelRenderMaterial class |
![]() | ModelRenderMaterial(RenderMaterial) | Initializes a new instance of the ModelRenderMaterial class |
Name | Description | |
---|---|---|
![]() | Name | (Overrides ModelContent.Name.) |
![]() | TypeName | (Overrides ModelRenderContent.TypeName.) |
![]() ![]() | Unset |
Name | Description | |
---|---|---|
![]() ![]() | Cast | |
![]() | CastTo<T>(T) | (Overrides ModelContent.CastTo<T>(T).) |
![]() | ToAttributes | |