GH_ParamT Methods |
The GH_ParamT generic type exposes the following members.
Name | Description | |
---|---|---|
AddRuntimeMessage |
Add a new message to this object. Valid message type flags are Warning and Error.
AddSource(IGH_Param) |
Append a new Source parameter to the end of the Sources list.
Sources provide this parameter with data at runtime.
| |
AddSource(IGH_Param, Int32) |
Insert a new Source parameter into the Sources list.
Sources provide this parameter with data at runtime.
| |
AddVolatileData(GH_Path, Int32, T) | ||
AddVolatileData(GH_Path, Int32, Object) |
Inserts an item of volatile data into the data structure.
| |
AddVolatileDataList(GH_Path, ListT) | ||
AddVolatileDataList(GH_Path, IEnumerable) | ||
AddVolatileDataTree(GH_StructureT) | ||
AddVolatileDataTree(IGH_Structure) | ||
AppendAdditionalMenuItems |
Override this function if you want to add specific items to the object context menu
Default items already included in the menu toolstrip are:
1. Name
2. Preview
3. Warnings
4. Errors
Cast_Object |
Attempts to convert the Object reference into an instance of T.
This method will perform a direct cast if possible or it will call Casting functions on T or Data if they exist.
Data will not be duplicated unless a type conversion is required.
| |
ClearData | (Overrides GH_ActiveObjectClearData.) | |
ClearProxySources |
Remove all proxy sources without attempting to relink them.
CollectData | (Overrides GH_ActiveObjectCollectData.) | |
CollectVolatileData_Custom |
If a parameter has no sources, the CollectVolatileData_Custom() method is called.
The basic implementation does nothing, but you can override this method to provide
special data instantiation logic.
| |
CollectVolatileData_FromSources |
This method collects volatile data from all the source parameters.
| |
ComputeData | (Overrides GH_ActiveObjectComputeData.) | |
ConversionCallback |
This method is called whenever a successful conversion takes
place from some source data into local target data.
Override it if you wish to keep tabs on conversions.
CreateAttributes | (Overrides GH_DocumentObjectCreateAttributes.) | |
CreateProxySources |
Convert all proper source parameters into proxy sources.
| |
ExpireSolution |
Informs the document that owns this object that the solution has expired.
The current object will be set to BLANK as a result. This method is recursive,
it will also expire any and all objects which depend on this object.
If you want a less destructive expiration, consider using ClearData().
ExpireSolutionTopLevel |
Invoke the Expiresolution(bool) method on the toplevel object.
| |
Format |
Returns "Null" if the data is a null reference, otherwise calls ToString() on the Data instance.
HtmlHelp_Source |
Return a String which contains HTML formatted source for the help topic.
If you want to pass a URL that points to a remote page, then prefix the URL with a GOTO: tag, like so:
InstantiateT |
Attempts to instantiate a new instance of T.
| |
Menu_AppendFlattenParameter | ||
Menu_AppendObjectName |
Appends the old-fashioned object name menu item. If you also want the
Menu_AppendSimplifyParameter | ||
NewInstanceGuid(Guid) |
Set the instance ID to be a specific GUID. This is very dangerous, only use this function
OnPingDocument |
Raise the PingDocument Event on the toplevel object and try to find
OnSolutionExpired |
Raises the SolutionExpired event on the toplevel object.
OnVolatileDataCollected |
Once volatile data has been collected this method will be calles. The basic
implementation does nothing, but you can add code here to post-process or
analyze the volatile data.
| |
PreferredCast |
Implement this function if you're certain that you'll be confronted with very common casts.
For example, GH_Point has a preferred cast from Rhino.Geometry.Point3d and GH_Number
has a preferred cast from System.Double.
| |
Preview_ComputeClippingBox |
This function can be used to iterate over all items in the Volatile data tree
and collect the union clipping box of all non-null items that implement
Preview.IGH_PreviewData. This function requires a lot of TypeOf and DirectCasting,
so if you're worried about performance you should consider doing this yourself.
| |
Preview_DrawMeshes |
This function can be used to iterate over all items in the Volatile data tree
and call DrawViewportWires on each item that implements Preview.IGH_PreviewData.
This function requires a lot of TypeOf and DirectCasting,
so if you're worried about performance you should consider doing this yourself.
| |
Preview_DrawWires |
This function can be used to iterate over all items in the Volatile data tree
and call DrawViewportWires on each item that implements Preview.IGH_PreviewData.
This function requires a lot of TypeOf and DirectCasting,
so if you're worried about performance you should consider doing this yourself.
| |
RegisterRemoteIDsUtil |
Utility function which treats all data in the Volatile cache as IGH_GeometricGoo
and registers all referenced objects. Call this function from within RegisterRemoteIDs()
if you are absolutely sure that all the items in volatiledata implement IGH_GeometricGoo.
| |
RelinkProxySources |
Attempt to replace all proxy sources with real sources.
Proxy sources are used during file IO, when actual sources might not be available yet.
Once an IO operation has been completed there should be no more proxy sources.
| |
RemoveAllSources |
Remove all sources from this parameter.
RemoveEffects |
Remove all post-process effects. Note to implementors,
you must call the base method if you override this function.
| |
RemoveSource(Guid) |
Remove the specified source from this parameter.
| |
RemoveSource(IGH_Param) |
Remove the specified source from this parameter.
| |
Render_AppendGeometry | Obsolete.
This function has been emptied because it is Obsolete.
| |
ReplaceSource(Guid, IGH_Param) |
Replace an existing source with a new one. If the old_source
does not exist in this parameter, nothing happens.
| |
ReplaceSource(IGH_Param, IGH_Param) |
Replace an existing source with a new one. If the old_source
does not exist in this parameter, nothing happens.
SetPrincipal |
Set the principal parameter state.
ValuesChanged |
Override this method if you want to respond to changes to the value table.
VolatileDataDescription |
This method is called to populate the Tooltip data description field.
| |