Click or drag to resize

StringWrapper Class

Represents a wrapper to an unmanaged OpenNurbs string.

Wraps a C++ ON_wString*.

Inheritance Hierarchy
SystemObject
  Rhino.Runtime.InteropWrappersStringWrapper

Namespace:  Rhino.Runtime.InteropWrappers
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public class StringWrapper : IDisposable

The StringWrapper type exposes the following members.

Constructors
  NameDescription
Public methodStringWrapper
Initializes a new empty unmanaged string (ON_wString*).
Public methodStringWrapper(String)
Initializes a new unmanaged string with an initial value. The string s can be null.
Top
Properties
  NameDescription
Public propertyConstPointer
Gets the constant pointer (constant ON_wString*).
Public propertyNonConstPointer
Gets the non-constant pointer (ON_wString*).
Top
Methods
  NameDescription
Public methodDispose
Actively reclaims unmanaged resources that this instance uses.
Protected methodFinalize
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.)
Public methodStatic memberGetStringFromPointer
Get string from an ON_wString*
Public methodSetString
Set contents of this string.
Public methodStatic memberSetStringOnPointer
Set contents of an ON_wString*
Public methodToString
Returns the string contents of this wrapper.
(Overrides ObjectToString.)
Top
See Also