Click or drag to resize

UserInterfaceSection Class

Note: This API is now obsolete.

Custom user interface section manager
Inheritance Hierarchy
SystemObject
  Rhino.Render.UIUserInterfaceSection

Namespace:  Rhino.Render.UI
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[ObsoleteAttribute("Obsolete")]
public class UserInterfaceSection

The UserInterfaceSection type exposes the following members.

Properties
  NameDescription
Public propertyRenderContent
The RenderContent object that created this user interface object.
Public propertyWindow
The user control associated with this user interface object.
Top
Methods
  NameDescription
Public methodExpand
Expand or collapse this content section.
Public methodStatic memberFromWindow
Find the UserInterfaceSection that created the specified instance of a window.
Public methodGetContentList
Returns a list of currently selected content items to be edited.
Public methodShow
Show or hide this content section.
Top
See Also