Click or drag to resize

DigitizerPlugIn Class

A Rhino plug-in that interfaces with 3-D digitizing or input devices.
Inheritance Hierarchy

Namespace:  Rhino.PlugIns
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class DigitizerPlugIn : PlugIn

The DigitizerPlugIn type exposes the following members.

Constructors
  NameDescription
Protected methodDigitizerPlugIn
Initializes a new instance of the DigitizerPlugIn class
Top
Properties
  NameDescription
Protected propertyDigitizerUnitSystem
Unit system of the points the digitizer passes to SendPoint(). Rhino uses this value when it calibrates a digitizer. This unit system must be not change.
Protected propertyPointTolerance
The point tolerance is the distance the digitizer must move (in digitizer coordinates) for a new point to be considered real rather than noise. Small desktop digitizer arms have values like 0.001 inches and 0.01 millimeters. This value should never be smaller than the accuracy of the digitizing device.
Top
Methods
  NameDescription
Protected methodEnableDigitizer
Called by Rhino to enable/disable input from the digitizer. If enable is true and EnableDigitizer() returns false, then Rhino will not calibrate the digitizer.
Public methodSendPoint
If the digitizer is enabled, call this function to send a point to Rhino. Call this function as much as you like. The digitizers that Rhino currently supports send a point every 15 milliseconds or so. This function should be called when users press or release any digitizer button.
Public methodSendRay
If the digitizer is enabled, call this function to send a point and direction to Rhino. Call this function as much as you like. The digitizers that Rhino currently supports send a point every 15 milliseconds or so. This function should be called when users press or release any digitizer button.
Top
Events
  NameDescription
Top
See Also