LengthValue Class |
Namespace: Rhino
The LengthValue type exposes the following members.
Name | Description | |
---|---|---|
ContextAngleUnitSystem |
Returns the context AngleUnitSystem from this LengthValue's ParseSettings
| |
ContextLocaleId |
returns the context LocaleId from this LengthValue
| |
LengthString |
Return length as a string
| |
LengthStringFormat |
Returns the StringFormat from this LengthValue
| |
ParseSettings | Parse settings | |
UnitSystem |
UnitSystem used by this LengthValue
|
Name | Description | |
---|---|---|
ChangeLength |
Changes the numeric value in a LengthValue and leaves all of the other info unchanged
UnitSystem, ParseSettings and StringFormat stay as they were
| |
ChangeUnitSystem |
Change the UnitSystem of a LengthValue
The numeric value of Length is scaled by new_us / current unit system
so that the absolute length stays the same
| |
Create(Double, UnitSystem, LengthValueStringFormat) | Create from Length and UnitSystem | |
Create(String, StringParserSettings, Boolean) | Create from string | |
Create(Double, UnitSystem, LengthValueStringFormat, UInt32) | Create from Length and UnitSystem | |
Dispose | actively reclaim native allocated ON_LenghtValue* | |
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) | |
Finalize | passively reclaim native allocated ON_LenghtValue* (Overrides ObjectFinalize.) | |
GetHashCode | Serves as the default hash function. (Inherited from Object.) | |
GetType | Gets the Type of the current instance. (Inherited from Object.) | |
IsUnset |
Test IsUnset
| |
Length |
Length value in this instance's current unit system
| |
Length(UnitSystem) | Length value in a given unit system | |
ToString | Returns a string that represents the current object. (Inherited from Object.) |