Click or drag to resize

LengthValue Methods

The LengthValue type exposes the following members.

Methods
  NameDescription
Public methodChangeLength
Changes the numeric value in a LengthValue and leaves all of the other info unchanged UnitSystem, ParseSettings and StringFormat stay as they were
Public methodChangeUnitSystem
Change the UnitSystem of a LengthValue The numeric value of Length is scaled by new_us / current unit system so that the absolute length stays the same
Public methodStatic memberCreate(Double, UnitSystem, LengthValueStringFormat)
Create from Length and UnitSystem
Public methodStatic memberCreate(String, StringParserSettings, Boolean)
Create from string
Public methodStatic memberCreate(Double, UnitSystem, LengthValueStringFormat, UInt32)
Create from Length and UnitSystem
Public methodDispose
actively reclaim native allocated ON_LenghtValue*
Protected methodFinalize
passively reclaim native allocated ON_LenghtValue*
(Overrides ObjectFinalize.)
Public methodIsUnset
Test IsUnset
Public methodLength
Length value in this instance's current unit system
Public methodLength(UnitSystem)
Length value in a given unit system
Top
See Also