Click or drag to resize

NurbsSurfacePointList Class

Provides access to the control points of a NURBS surface.
Inheritance Hierarchy
SystemObject
  Rhino.Geometry.CollectionsNurbsSurfacePointList

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class NurbsSurfacePointList : IEnumerable<ControlPoint>, 
	IEnumerable, IEpsilonComparable<NurbsSurfacePointList>

The NurbsSurfacePointList type exposes the following members.

Properties
  NameDescription
Public propertyCountU
Gets the number of control points in the U direction of this surface.
Public propertyCountV
Gets the number of control points in the V direction of this surface.
Public propertyPointSize
Returns the control point size, or the number of doubles per control point. For rational curves, PointSize = Surface.Dimension + 1. For non-rational curves, PointSize = Surface.Dimension.
Top
Methods
  NameDescription
Public methodEnsurePrivateCopy
If you want to keep a copy of this class around by holding onto it in a variable after a command completes, call EnsurePrivateCopy to make sure that this class is not tied to the document. You can call this function as many times as you want.
Public methodEpsilonEquals
Check that all values in other are within epsilon of the values in this
Public methodGetControlPoint
Gets the control point at the given (u, v) index.
Public methodGetGrevillePoint
Gets the 2-D Greville point associated with the control point at the given (u, v) index.
Public methodGetPoint(Int32, Int32, Point3d)
Gets a world 3-D, or Euclidean, control point at the given (u, v) index. The 4-D representation is (x, y, z, 1.0).
Public methodGetPoint(Int32, Int32, Point4d)
Gets a homogeneous control point at the given (u, v) index, where the 4-D representation is (x, y, z, w). The world 3-D, or Euclidean, representation is (x/w, y/w, z/w).
Public methodGetWeight
Gets the weight of a control point at the given (u, v) index. Note, if the surface is non-rational, the weight will be 1.0.
Public methodSetControlPoint(Int32, Int32, ControlPoint)
Sets the control point at the given (u, v) index.
Public methodSetControlPoint(Int32, Int32, Point3d) Obsolete.
Sets the control point at the given (u, v) index.
Public methodSetPoint(Int32, Int32, Point3d)
Sets a world 3-D, or Euclidean, control point at the given (u, v) index. The 4-D representation is (x, y, z, 1.0).
Public methodSetPoint(Int32, Int32, Point4d)
Sets a homogeneous control point at the given (u, v) index, where the 4-D representation is (x, y, z, w). The world 3-D, or Euclidean, representation is (x/w, y/w, z/w).
Public methodSetPoint(Int32, Int32, Point3d, Double)
Sets a world 3-D, or Euclidean, control point and weight at a given index. The 4-D representation is (x*w, y*w, z*w, w).
Public methodSetPoint(Int32, Int32, Double, Double, Double)
Sets a world 3-D, or Euclidean, control point at the given (u, v) index. The 4-D representation is (x, y, z, 1.0).
Public methodSetPoint(Int32, Int32, Double, Double, Double, Double)
Sets a homogeneous control point at the given (u, v) index, where the 4-D representation is (x, y, z, w). The world 3-D, or Euclidean, representation is (x/w, y/w, z/w).
Public methodSetWeight
Sets the weight of a control point at the given (u, v) index. Note, if the surface is non-rational, it will be converted to rational.
Public methodUVNDirectionsAt
Calculates the U, V, and N directions of a NURBS surface control point similar to the method used by Rhino's MoveUVN command.
Public methodValidateSpacing
Simple check of distance between adjacent control points
Top
See Also