Click or drag to resize

NurbsSurfacePointListValidateSpacing Method

Simple check of distance between adjacent control points

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public bool ValidateSpacing(
	double closeTolerance,
	double stackTolerance,
	out IndexPair[] closeIndices,
	out IndexPair[] stackedIndices
)

Parameters

closeTolerance
Type: SystemDouble

[Missing <param name="closeTolerance"/> documentation for "M:Rhino.Geometry.Collections.NurbsSurfacePointList.ValidateSpacing(System.Double,System.Double,Rhino.IndexPair[]@,Rhino.IndexPair[]@)"]

stackTolerance
Type: SystemDouble

[Missing <param name="stackTolerance"/> documentation for "M:Rhino.Geometry.Collections.NurbsSurfacePointList.ValidateSpacing(System.Double,System.Double,Rhino.IndexPair[]@,Rhino.IndexPair[]@)"]

closeIndices
Type: RhinoIndexPair

[Missing <param name="closeIndices"/> documentation for "M:Rhino.Geometry.Collections.NurbsSurfacePointList.ValidateSpacing(System.Double,System.Double,Rhino.IndexPair[]@,Rhino.IndexPair[]@)"]

stackedIndices
Type: RhinoIndexPair

[Missing <param name="stackedIndices"/> documentation for "M:Rhino.Geometry.Collections.NurbsSurfacePointList.ValidateSpacing(System.Double,System.Double,Rhino.IndexPair[]@,Rhino.IndexPair[]@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Rhino.Geometry.Collections.NurbsSurfacePointList.ValidateSpacing(System.Double,System.Double,Rhino.IndexPair[]@,Rhino.IndexPair[]@)"]

See Also