Click or drag to resize

NurbsSurfacePointListSetPoint Method (Int32, Int32, Point3d)

Sets a world 3-D, or Euclidean, control point at the given (u, v) index. The 4-D representation is (x, y, z, 1.0).

Namespace:  Rhino.Geometry.Collections
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public bool SetPoint(
	int u,
	int v,
	Point3d point
)

Parameters

u
Type: SystemInt32
Index of control point in the surface U direction.
v
Type: SystemInt32
Index of control point in the surface V direction.
point
Type: Rhino.GeometryPoint3d
Coordinate of control point.

Return Value

Type: Boolean
true on success, false on failure.
See Also