Click or drag to resize

SnapShotsClient Class

This is the abstract interface class for all Snapshot clients.
Inheritance Hierarchy
SystemObject
  Rhino.DocObjects.SnapShotsSnapShotsClient

Namespace:  Rhino.DocObjects.SnapShots
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public abstract class SnapShotsClient : IDisposable

The SnapShotsClient type exposes the following members.

Constructors
  NameDescription
Public methodSnapShotsClient
SnapShotsClient constructor
Top
Properties
  NameDescription
Public propertyCppPointer
Public propertySerialNumber
Top
Methods
  NameDescription
Public methodAnimateDocument
Called for each frame. Starting at 0.0.
Public methodAnimateObject
Called for each frame. Starting at 0.0.
Public methodAnimationStart
Called once at the start of an animation.
Public methodAnimationStop
Called once at the end of an animation.
Public methodStatic memberApplicationCategory
Predefined application category
Public methodCategory
The category of this client. Usually one of the above predefined categories like e.g object, rendering or application category
Public methodClientId
The unique id of this client.
Public methodDispose
SnapShotsClient Dispose
Public methodStatic memberDocumentCategory
Predefined document category
Public methodExtendBoundingBoxForDocumentAnimation
Called once at the start of an animation. This can be used to extend the scene bounding box to avoid clipping.
Public methodExtendBoundingBoxForObjectAnimation
Called once at the start of an animation. This can be used to extend the scene bounding box to avoid clipping.
Public methodIsCurrentModelStateInAnySnapshot(RhinoDoc, BinaryArchiveReader, SimpleArrayBinaryArchiveReader, TextLog)
Called before restoring a snapshot. Warns the user if the current model state is not already saved.
Public methodIsCurrentModelStateInAnySnapshot(RhinoDoc, RhinoObject, BinaryArchiveReader, SimpleArrayBinaryArchiveReader, TextLog)
Called before restoring a snapshot. Warns the user if the current model state is not already saved.
Public methodStatic memberLayersCategory
Predefined layers category
Public methodStatic memberLightsCategory
Predefined lights category
Public methodName
The client's name.
Public methodStatic memberObjectsCategory
Predefined objects category
Public methodObjectTransformNotification
Called for every object that is associated with a snapshot and gets transformed in Rhino. This is getting called for each stored snapshot and gives the client the possibility to update the stored data.
Public methodPlugInId
The plug-in id that registers this client.
Public methodPrepareForDocumentAnimation
Called once at the start of an animation.
Public methodPrepareForObjectAnimation
Called once at the start of an animation.
Public methodStatic memberRegisterSnapShotClient
Function used to register snapshots client
Public methodStatic memberRenderingCategory
Predefined rendering category
Public methodRestoreDocument
Called when the user restores a snapshot and SupportDocument() returns true.
Public methodRestoreObject
Called when the user restores a snapshot and SupportsObjects() and SupportsObject(Rhino.DocObjects.RhinoObject doc_object) returns true.
Public methodSaveDocument
Called when the user saves a snapshot and SupportDocument() returns true.
Public methodSaveObject
Called when the user saves a snapshot and SupportsObjects() and SupportsObject(Rhino.DocObjects.RhinoObject doc_object) returns true.
Public methodSnapshotRestored
Called after all clients restored their data.
Public methodSupportsAnimation
Returns true if the client allows animation.
Public methodSupportsDocument
Defines if the client supports document user data or not
Public methodSupportsObject
Returns true if the client saves/restores object user data for the given object.
Public methodSupportsObjects
Returns true if the client saves/restores object user data.
Public methodStatic memberViewsCategory
Predefined views category
Top
See Also