Click or drag to resize

SnapShotsClientIsCurrentModelStateInAnySnapshot Method (RhinoDoc, BinaryArchiveReader, SimpleArrayBinaryArchiveReader, TextLog)

Called before restoring a snapshot. Warns the user if the current model state is not already saved.

Namespace:  Rhino.DocObjects.SnapShots
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public abstract bool IsCurrentModelStateInAnySnapshot(
	RhinoDoc doc,
	BinaryArchiveReader archive,
	SimpleArrayBinaryArchiveReader archive_array,
	TextLog text_log = null
)

Parameters

doc
Type: RhinoRhinoDoc
doc is the current document.
archive
Type: Rhino.FileIOBinaryArchiveReader
archive is the current state of the model.
archive_array
Type: Rhino.Runtime.InteropWrappersSimpleArrayBinaryArchiveReader
archive_array is a list of client data.
text_log (Optional)
Type: Rhino.FileIOTextLog
text_log is used to list the missing items that cannot be found in the current model.

Return Value

Type: Boolean
return true if successful, otherwise false.
See Also