SimpleArrayBinaryArchiveReader Class |
Namespace: Rhino.Runtime.InteropWrappers
The SimpleArrayBinaryArchiveReader type exposes the following members.
Name | Description | |
---|---|---|
SimpleArrayBinaryArchiveReader |
Initializes a new SimpleArrayBinaryArchiveReader class.
| |
SimpleArrayBinaryArchiveReader(IntPtr) |
Initializes a new SimpleArrayBinaryArchiveReader class.
|
Name | Description | |
---|---|---|
Add |
Adds a new Interval at the end of this array.
| |
ConstPointer |
Gets the constant (immutable) pointer of this array.
| |
Dispose |
Actively reclaims unmanaged resources that this instance uses.
| |
Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.) | |
Finalize |
Passively reclaims unmanaged resources when the class user did not explicitly call Dispose().
(Overrides ObjectFinalize.) | |
Get |
Get the Guid at index
| |
GetHashCode | Serves as the default hash function. (Inherited from Object.) | |
GetType | Gets the Type of the current instance. (Inherited from Object.) | |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.) | |
NonConstPointer |
Gets the non-constant pointer (for modification) of this array.
| |
ToString | Returns a string that represents the current object. (Inherited from Object.) |