Click or drag to resize

SnapShotsClientRestoreObject Method

Called when the user restores a snapshot and SupportsObjects() and SupportsObject(Rhino.DocObjects.RhinoObject doc_object) returns true.

Namespace:  Rhino.DocObjects.SnapShots
Assembly:  RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax
public abstract bool RestoreObject(
	RhinoDoc doc,
	RhinoObject doc_object,
	ref Transform transform,
	BinaryArchiveReader archive
)

Parameters

doc
Type: RhinoRhinoDoc
doc is the current document.
doc_object
Type: Rhino.DocObjectsRhinoObject
doc_obj is the current object.
transform
Type: Rhino.GeometryTransform
transform is a transformation matrix. The matrix is set to identity the first time an object is associated with a snapshot. After that the matrix is updated when the object is transformed(scale, rotate etc.).
archive
Type: Rhino.FileIOBinaryArchiveReader
archive is the archive to read the data from.

Return Value

Type: Boolean
true if successful, otherwise false.
See Also