SnapShotsClientRestoreDocument Method |
Called when the user restores a snapshot and SupportDocument() returns true.
Namespace:
Rhino.DocObjects.SnapShots
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax public abstract bool RestoreDocument(
RhinoDoc doc,
BinaryArchiveReader archive
)
Public MustOverride Function RestoreDocument (
doc As RhinoDoc,
archive As BinaryArchiveReader
) As Boolean
Parameters
- doc
- Type: RhinoRhinoDoc
doc is the current document - archive
- Type: Rhino.FileIOBinaryArchiveReader
archive is the archive to read the data from
Return Value
Type:
Booleantrue if successful, otherwise false
See Also