SnapShotsClientSaveDocument Method |
Called when the user saves a snapshot and SupportDocument() returns true.
Namespace:
Rhino.DocObjects.SnapShots
Assembly:
RhinoCommon (in RhinoCommon.dll)
Since: 6.0
Syntax public abstract bool SaveDocument(
RhinoDoc doc,
BinaryArchiveWriter archive
)
Public MustOverride Function SaveDocument (
doc As RhinoDoc,
archive As BinaryArchiveWriter
) As Boolean
Parameters
- doc
- Type: RhinoRhinoDoc
doc is the current document - archive
- Type: Rhino.FileIOBinaryArchiveWriter
archive is the archive to write the data to
Return Value
Type:
Booleantrue if successful, otherwise false
See Also