Click or drag to resize

DisplayModeDescription Class

Description of a how Rhino will display in a viewport. These are the modes that are listed under "Advanced display" in the options dialog.
Inheritance Hierarchy
SystemObject
  Rhino.DisplayDisplayModeDescription

Namespace:  Rhino.Display
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
[SerializableAttribute]
public class DisplayModeDescription : IDisposable, 
	ISerializable

The DisplayModeDescription type exposes the following members.

Properties
Methods
  NameDescription
Public methodStatic memberAddDisplayMode(DisplayModeDescription)
Public methodStatic memberAddDisplayMode(String)
Adds a new display mode.
Public methodStatic memberCopyDisplayMode
Copies an existing display mode.
Public methodStatic memberDeleteDiplayMode Obsolete.
Deletes an existing display mode.
Public methodStatic memberDeleteDisplayMode
Deletes an existing display mode.
Public methodDispose
Releases all resources used by the DisplayModeDescription
Protected methodDispose(Boolean)
Releases the unmanaged resources used by the DisplayModeDescription and optionally releases the managed resources
Public methodStatic memberExportToFile
Exports a DisplayModeDescription to a Windows-style .ini file.
Protected methodFinalize (Overrides ObjectFinalize.)
Public methodStatic memberFindByName
Public methodStatic memberGetDisplayMode
Public methodStatic memberCode exampleGetDisplayModes
Gets all display mode descriptions that Rhino currently knows about.
Public methodStatic memberImportFromFile
Imports a DisplayModeDescription from a Windows-style .ini file.
Public methodStatic memberCode exampleUpdateDisplayMode
Top
See Also