Click or drag to resize

Vector2d Properties

The Vector2d type exposes the following members.

Properties
  NameDescription
Public propertyIsValid
Gets a value indicating whether this vector is valid. A valid vector must be formed of valid component values for x, y and z.
Public propertyLength
Computes the length (or magnitude, or size) of this vector. This is an application of Pythagoras' theorem.
Public propertySquareLength
Returns the square of the length of the vector.
Public propertyStatic memberUnset
Gets the value of the vector with components set as RhinoMath.UnsetValue,RhinoMath.UnsetValue.
Public propertyX
Gets or sets the X (first) component of this vector.
Public propertyY
Gets or sets the Y (second) component of this vector.
Public propertyStatic memberZero
Gets the value of the vector with components 0,0.
Top
See Also