MorphControl Properties |
The MorphControl type exposes the following members.
Name | Description | |
---|---|---|
Curve |
Returns the morph control's curve. While this should never be null, the
calling function should check.
IsDeformable |
true if object can be accurately modified with "squishy" transformations like
IsDocumentControlled |
If true this object may not be modified. Any properties or functions that attempt
ObjectType |
Useful for switch statements that need to differentiate between
PreserveStructure |
true if the morph should be done in a way that preserves the structure
of the geometry. In particular, for NURBS objects, true means that
only the control points are moved. The PreserveStructure value does not
affect the way meshes and points are morphed. The default is false.
| |
QuickPreview |
true if the morph should be done as quickly as possible because the
result is being used for some type of dynamic preview. If QuickPreview
is true, the tolerance may be ignored. The QuickPreview value does not
affect the way meshes and points are morphed. The default is false.
| |
SpaceMorphTolerance |
The 3d fitting tolerance used when morphing surfaces and breps.
The default is 0.0 and any value <= 0.0 is ignored by morphing functions.
The value returned by Tolerance does not affect the way meshes and points are morphed.
| |
Surface |
Returns the morph control's surface. While this should never be null, the
calling function should check.
UserDictionary |
Dictionary of custom information attached to this class. The dictionary is actually user