Click or drag to resize

Mesh Properties

The Mesh type exposes the following members.

Properties
  NameDescription
Public propertyComponentStates
Gets access to the vertex hidden/visibility collection in this mesh. This is a runtime property and it is not saved in the 3dm file.
Public propertyDisjointMeshCount
Gets the number of disjoint (topologically unconnected) pieces in this mesh.
Public propertyFaceNormals
Gets access to the face normal collection in this mesh.
Public propertyCode exampleFaces
Gets access to the mesh face list.
Public propertyHasCachedTextureCoordinates
Will return true if SetCachedTextureCoordinates has been called; otherwise will return false.
Public propertyHasPrincipalCurvatures
HasPrincipalCurvatures
Public propertyIsClosed
Returns true if every mesh "edge" has two or more faces.
Public propertyIsOriented
Returns true if the mesh is manifold and every pair of faces that share an "edge" have compatible orientations.
Public propertyIsSolid
Returns true if the mesh is solid. A "solid" is a closed oriented manifold.
Public propertyNgons
Gets access to the mesh ngon list.

Ngons represent groups of Faces (triangles + quads).

Faces are used to tessellate an Ngon internally.

When a triangle or quad is referenced in the Ngon list, it is no longer visualized and conceived as a single entity, but takes part of the Ngon.

If you need to get access to both Ngons and the faces that are not referenced by Ngons, that is, all polygons that are visible in the mesh, then use the GetNgonAndFacesEnumerable helper method.

Public propertyCode exampleNormals
Gets access to the vertex normal collection in this mesh.
Public propertyPartitionCount
Number of partition information chunks stored on this mesh based on the last call to CreatePartitions
Public propertyTextureCoordinates
Gets access to the vertex texture coordinate collection in this mesh.
Public propertyTopologyEdges
Gets the MeshTopologyEdgeList object associated with this mesh.

This object stores edge connectivity.

Public propertyTopologyVertices
Gets the MeshTopologyVertexList object associated with this mesh.

This object stores vertex connectivity and the indices of vertices that were unified while computing the edge topology.

Public propertyVertexColors
Gets access to the (optional) vertex color collection in this mesh.
Public propertyCode exampleVertices
Gets access to the vertices set of this mesh.
Top
See Also