Click or drag to resize

ViewportInfo Properties

The ViewportInfo type exposes the following members.

Properties
  NameDescription
Public propertyCamera35mmLensLength
This property assumes the camera is horizontal and crop the film rather than the image when the aspect of the frustum is not 36/24. (35mm film is 36mm wide and 24mm high.) Setting preserves camera location, changes the frustum, but maintains the frustum's aspect.
Public propertyCameraAngle
Public propertyCameraDirection
Gets the direction that the camera faces.
Public propertyCameraLocation
Gets the camera location (position) point.
Public propertyCameraUp
Gets the camera up vector.
Public propertyCameraX
Gets the unit "to the right" vector.
Public propertyCameraY
Gets the unit "up" vector.
Public propertyCameraZ
Gets the unit vector in -CameraDirection.
Public propertyStatic memberDefaultCameraDirection
Default z=up perspective camera direction
Public propertyFrustumAspect
Setting FrustumAspect changes the larger of the frustum's width/height so that the resulting value of width/height matches the requested aspect. The camera angle is not changed. If you change the shape of the view port with a call SetScreenPort(), then you generally want to call SetFrustumAspect() with the value returned by GetScreenPortAspect().
Public propertyFrustumBottom
Gets the frustum bottom value. This is -top if the frustum has a horizontal symmetry axis.

This number is usually negative.

Public propertyFrustumBottomPlane
Gets the frustum bottom plane that separates visible from off-screen.
Public propertyFrustumCenter
Gets the frustum center point.
Public propertyFrustumFar
Gets the frustum far-cutting value.
Public propertyFrustumFarPlane
Gets far clipping plane if camera and frustum are valid. The plane's frame is the same as the camera's frame. The origin is located at the intersection of the camera direction ray and the far clipping plane. The plane's normal points into the frustum towards the camera location.
Public propertyFrustumHeight
Gets the frustum height. This is FrustumTop - FrustumBottom.
Public propertyFrustumLeft
Gets the frustum left value. This is -right if the frustum has a vertical symmetry axis.

This number is usually negative.

Public propertyFrustumLeftPlane
Gets the frustum left plane that separates visible from off-screen.
Public propertyFrustumMaximumDiameter
Gets the frustum maximum diameter, or the maximum between FrustumWidth and FrustumHeight.
Public propertyFrustumMinimumDiameter
Gets the frustum minimum diameter, or the minimum between FrustumWidth and FrustumHeight.
Public propertyFrustumNear
Gets the frustum near-cutting value.
Public propertyFrustumNearPlane
Gets near clipping plane if camera and frustum are valid. The plane's frame is the same as the camera's frame. The origin is located at the intersection of the camera direction ray and the near clipping plane. The plane's normal points out of the frustum towards the camera location.
Public propertyFrustumRight
Gets the frustum right value. This is -left if the frustum has a vertical symmetry axis.

This number is usually positive.

Public propertyFrustumRightPlane
Gets the frustum right plane that separates visible from off-screen.
Public propertyFrustumTop
Gets the frustum top value. This is -bottom if the frustum has a horizontal symmetry axis.

This number is usually positive.

Public propertyFrustumTopPlane
Gets the frustum top plane that separates visible from off-screen.
Public propertyFrustumWidth
Gets the frustum width. This is FrustumRight - FrustumLeft.
Public propertyId
Sets the viewport's id to the value used to uniquely identify this viewport. There is no approved way to change the viewport id once it is set in order to maintain consistency across multiple viewports and those routines that manage them.
Public propertyIsCameraDirectionLocked
Gets or sets a value that indicates whether the direction that the camera faces is unmodifiable.
Public propertyIsCameraLocationLocked
Gets or sets a value that indicates whether the camera location is unmodifiable.
Public propertyIsCameraUpLocked
Gets or sets a value that indicates whether the camera up vector is unmodifiable.
Public propertyIsFrustumLeftRightSymmetric
Gets or sets a value that indicates whether the camera frustum has a vertical symmetry axis.
Public propertyIsFrustumTopBottomSymmetric
Gets or sets a value that indicates whether the camera frustum has a horizontal symmetry axis.
Public propertyIsParallelProjection
Get or set whether this projection is parallel.
Public propertyIsPerspectiveProjection
Get or set whether this projection is perspective.
Public propertyIsTwoPointPerspectiveProjection
Gets a value that indicates whether this projection is a two-point perspective.
Public propertyIsValidCamera
Gets a value that indicates whether the camera is valid.
Public propertyIsValidFrustum
Gets a value that indicates whether the frustum is valid.
Public propertyPerspectiveMinNearDist
Expert user function to control the minimum value of near when perspective projections are being used.
Public propertyPerspectiveMinNearOverFar
Expert user function to control the minimum ratio of near/far when perspective projections are begin used.
Public propertyScreenPort
Get or set the screen port. SetScreenPort(Rectangle) and
Public propertyScreenPortAspect
Gets the screen aspect ratio.

This is width / height.

Public propertyTargetPoint
The current value of the target point. This point does not play a role in the view projection calculations. It can be used as a fixed point when changing the camera so the visible regions of the before and after frustums both contain the region of interest. The default constructor sets this point on ON_3dPoint::UnsetPoint. You must explicitly call one SetTargetPoint() functions to set the target point.
Public propertyViewScale
Applies scaling factors to parallel projection clipping coordinates by setting the m_clip_mod transformation. If you want to compress the view projection across the viewing plane, then set x = 0.5, y = 1.0, and z = 1.0.
Top
See Also