Click or drag to resize

RhinoObject Properties

The RhinoObject type exposes the following members.

Properties
  NameDescription
Public propertyAttributes
Gets or sets the object attributes.
Public propertyComponentType
Returns ModelGeometry.
(Overrides ModelComponentComponentType.)
Public propertyDocument
Gets the document that owns this object.
Public propertyGeometry
Gets the underlying geometry for this object.

All rhino objects are composed of geometry and attributes.

Public propertyGripsOn
Gets or sets the activation state of object default editing grips.
Public propertyGripsSelected
true if grips are turned on and at least one is selected.
Public propertyGroupCount
Number of groups object belongs to.
Public propertyHasDynamicTransform
True if the object has a dynamic transformation
Public propertyHasSubobjectMaterials
Will be true if the object contains sub object meshes with materials that are different than the top level object.
Public propertyId
Every object has a Guid (globally unique identifier, also known as UUID, or universally unique identifier). The default value is Guid.Empty.

When an object is added to a model, the value is checked. If the value is Guid.Empty, a new Guid is created. If the value is not null but it is already used by another object in the model, a new Guid is created. If the value is not Guid.Empty and it is not used by another object in the model, then that value persists. When an object is updated, by a move for example, the value of ObjectId persists.

This value is the same as the one returned by this.Attributes.ObjectId.

(Overrides ModelComponentId.)
Public propertyInstanceDefinitionModelSerialNumber
When a component is in a model as part of the information required for a linked instance definition, this value identifies the linked instance definition reference model.
(Overrides ModelComponentInstanceDefinitionModelSerialNumber.)
Public propertyIsDeletable
Some objects cannot be deleted, like grips on lights and annotation objects.
Public propertyIsDeleted
true if the object is deleted. Deleted objects are kept by the document for undo purposes. Call RhinoDoc.UndeleteObject to undelete an object.
(Overrides ModelComponentIsDeleted.)
Public propertyIsHidden
An object must be in one of three modes: normal, locked or hidden. If an object is in normal mode, then the object's layer controls visibility and selectability. If an object is locked, then the object's layer controls visibility by the object cannot be selected. If the object is hidden, it is not visible and it cannot be selected.
Public propertyIsInstanceDefinitionGeometry
true if the object is used as part of an instance definition.
Public propertyIsLocked
An object must be in one of three modes: normal, locked or hidden. If an object is in normal mode, then the object's layer controls visibility and selectability. If an object is locked, then the object's layer controls visibility by the object cannot be selected. If the object is hidden, it is not visible and it cannot be selected.
Public propertyIsNormal
An object must be in one of three modes: normal, locked or hidden. If an object is in normal mode, then the object's layer controls visibility and selectability. If an object is locked, then the object's layer controls visibility by the object cannot be selected. If the object is hidden, it is not visible and it cannot be selected.
Public propertyIsPictureFrame
Returns true if the object is a picture frame. A picture frame object is an object that displays a texture map in all views.
Public propertyIsReference
Gets a value indicating if an object is a reference object. An object from a work session reference model is a reference object and cannot be modified. An object is a reference object if, and only if, it is on a reference layer.
(Overrides ModelComponentIsReference.)
Public propertyIsSolid
Returns true if object is a closed solid, otherwise false.
Public propertyIsSystemComponent
True if this model component is a system constant.

An incomplete list of system constant model components is below:

  • ON_ModelComponent::Unset

  • ON_InstanceDefinition::Empty

  • ON_Linetype::Unset
  • ON_Linetype::Continuous
  • ON_Linetype::ByLayer
  • ON_Linetype::ByParent

  • ON_Layer::Unset
  • ON_Layer::Default

  • ON_TextStyle::Unset
  • ON_TextStyle::Default
  • ON_TextStyle::ByLayer
  • ON_TextStyle::ByParent

  • ON_DimStyle::Unset
  • ON_DimStyle::Default
  • ON_DimStyle::DefaultInchDecimal
  • ON_DimStyle::DefaultInchFractional
  • ON_DimStyle::DefaultFootInchArchitecture
  • ON_DimStyle::DefaultMillimeterSmall
  • ON_DimStyle::DefaultMillimeterLarge
Public propertyName
Rhino objects have optional text names. More than one object in a model can have the same name and some objects may have no name.
(Overrides ModelComponentName.)
Public propertyStatic memberNextRuntimeSerialNumber
Gets the runtime serial number that will be assigned to the next Rhino Object that is created.
Public propertyObjectType
Gets the Rhino-based object type.
Public propertyReferenceModelSerialNumber
When a component is in a model for reference, this value identifies the reference model.
(Overrides ModelComponentReferenceModelSerialNumber.)
Public propertyRenderMaterial
Gets the render material associated with this object or null if there is none. This does not pay attention to the material source and will not check parent objects or layers for a RenderMaterial.
Public propertyRuntimeSerialNumber
Gets the objects runtime serial number.
Public propertySubobjectMaterialComponents
Public propertyVisible
Gets the object visibility.
Top
See Also