PointObject Properties |
The PointObject type exposes the following members.
Name | Description | |
---|---|---|
Disposed |
Indicates if this object has been disposed or the
HasSubobjectMaterials |
Will be true if the object contains sub object meshes with materials
Id |
Every object has a Guid (globally unique identifier, also known as UUID, or universally
InstanceDefinitionModelSerialNumber |
When a component is in a model as part of the information required for a linked instance definition,
IsDeleted |
true if the object is deleted. Deleted objects are kept by the document
IsDocumentControlled |
If true this object may not be modified. Any properties or functions that attempt
IsHidden |
An object must be in one of three modes: normal, locked or hidden.
If an object is in normal mode, then the object's layer controls visibility
and selectability. If an object is locked, then the object's layer controls
visibility by the object cannot be selected. If the object is hidden, it is
IsLocked |
An object must be in one of three modes: normal, locked or hidden.
If an object is in normal mode, then the object's layer controls visibility
and selectability. If an object is locked, then the object's layer controls
visibility by the object cannot be selected. If the object is hidden, it is
IsNormal |
An object must be in one of three modes: normal, locked or hidden.
If an object is in normal mode, then the object's layer controls visibility
and selectability. If an object is locked, then the object's layer controls
visibility by the object cannot be selected. If the object is hidden, it is
IsPictureFrame |
Returns true if the object is a picture frame.
IsReference |
Gets a value indicating if an object is a reference object. An object from a work session
reference model is a reference object and cannot be modified. An object is
| |
Name |
Rhino objects have optional text names. More than one object in
RenderMaterial |
Gets the render material associated with this object or null if there
is none. This does not pay attention to the material source and will
UserDictionary |
Dictionary of custom information attached to this class. The dictionary is actually user