Group Properties |
The Group type exposes the following members.
Name | Description | |
---|---|---|
![]() | ComponentStatus |
Gets or sets the component status of the model component.
(Inherited from ModelComponent.) |
![]() | ComponentType |
Returns Group.
(Overrides ModelComponentComponentType.) |
![]() | DeletedName |
Gets the name of a component that is deleted.
(Inherited from ModelComponent.) |
![]() | Disposed |
Indicates if this object has been disposed or the
document it originally belonged to has been disposed.
(Inherited from CommonObject.) |
![]() | HasId |
Returns a value indicating whether the component has an ID.
(Inherited from ModelComponent.) |
![]() | HasIndex |
Returns a value indicating whether the component has an Index.
(Inherited from ModelComponent.) |
![]() | HasName |
Returns a value indicating whether the component has a Name.
(Inherited from ModelComponent.) |
![]() | HasUserData |
Gets true if this class has any custom information attached to it through UserData.
(Inherited from CommonObject.) |
![]() | Id |
Gets or sets the ID of the current instance.
(Inherited from ModelComponent.) |
![]() | IdIsLocked |
Returns a value indicating whether the component ID is already locked.
(Inherited from ModelComponent.) |
![]() | Index |
Gets or sets the model component index attribute.
(Inherited from ModelComponent.) |
![]() | IndexIsLocked |
Returns a value indicating whether the component Index is already locked.
(Inherited from ModelComponent.) |
![]() | InstanceDefinitionModelSerialNumber |
When a component is in a model as part of the information required for a linked instance definition,
this value identifies the linked instance definition reference model.
(Inherited from ModelComponent.) |
![]() | IsComponentStatusLocked |
The component status itself can be locked. This returns an indication.
(Inherited from ModelComponent.) |
![]() | IsDeleted |
true if the component is deleted.
Deleted components are kept by the document for undo purposes.
(Inherited from ModelComponent.) |
![]() | IsDocumentControlled |
If true this object may not be modified. Any properties or functions that attempt
to modify this object when it is set to "IsReadOnly" will throw a NotSupportedException.
(Inherited from CommonObject.) |
![]() | IsReference |
Gets a value indicting whether this component is a referenced component.
Referenced components are part of referenced documents.
(Inherited from ModelComponent.) |
![]() | IsSystemComponent |
True if this model component is a system constant.
(Inherited from ModelComponent.)An incomplete list of system constant model components is below:
|
![]() | IsValid | Tests an object to see if it is valid. (Inherited from CommonObject.) |
![]() | ModelSerialNumber |
A value identifying the model that manages this component.
(Inherited from ModelComponent.) |
![]() ![]() | Name |
Gets or sets the name
(Inherited from ModelComponent.) |
![]() | NameIsLocked |
Returns a value indicating whether the component Name is already locked.
(Inherited from ModelComponent.) |
![]() | ReferenceModelSerialNumber |
When a component is in a model for reference, this value identifies the reference model.
(Inherited from ModelComponent.) |
![]() | UserData |
List of custom information that is attached to this class.
(Inherited from CommonObject.) |
![]() | UserDictionary |
Dictionary of custom information attached to this class. The dictionary is actually user
data provided as an easy to use shareable set of information.
(Inherited from CommonObject.) |
![]() | UserStringCount |
Gets the amount of user strings.
|