Click or drag to resize

DimensionStyle Properties

The DimensionStyle type exposes the following members.

Properties
  NameDescription
Public propertyAlternateBelowLine
Public propertyAlternateDimensionLengthDisplay
Public propertyAlternateLengthFactor
Public propertyAlternateLengthResolution
Public propertyAlternatePrefix
Public propertyAlternateRoundoff
Public propertyAlternateSuffix
Public propertyAlternateToleranceResolution
Public propertyAlternateUnitsDisplay
Public propertyAlternateZeroSuppress
Public propertyAngleFormat
Public propertyAngleResolution
Public propertyAngleZeroSuppress
Public propertyAngularRoundoff
Public propertyArcLengthSymbol
Public propertyArrowBlockId1
Public propertyArrowBlockId2
Public propertyArrowLength
Public propertyArrowType1
Public propertyArrowType2
Public propertyBaselineSpacing
Public propertyCentermarkSize
Public propertyCenterMarkType
Public propertyComponentType
Returns DimStyle.
(Overrides ModelComponentComponentType.)
Public propertyDecimalSeparator
Public propertyDimensionLengthDisplay
Public propertyDimensionLineExtension
Public propertyDimensionScale
Public propertyDimensionScaleValue
Public propertyDimRadialTextAngleType
Public propertyDimRadialTextLocation
Public propertyDimRadialTextOrientation
Public propertyDimTextAngleType
Public propertyDimTextLocation
Public propertyDimTextOrientation
Public propertyDrawForward
Public propertyDrawTextMask
Public propertyExtensionLineExtension
Public propertyExtensionLineOffset
Public propertyFitArrow
Public propertyFitText
Public propertyFixedExtensionLength
Public propertyFixedExtensionOn
Public propertyFont
Public propertyForceDimensionLineBetweenExtensionLines
Public propertyHasFieldOverrides
Checks if any fields in this DimensionStyle are overrides
Public propertyIsChild
Tests if this DimensionStyle is a child of any other DimensionStyle
Public propertyIsDeleted (Overrides ModelComponentIsDeleted.)
Public propertyIsReference (Overrides ModelComponentIsReference.)
Public propertyIsSystemComponent
True if this model component is a system constant.

An incomplete list of system constant model components is below:

  • ON_ModelComponent::Unset

  • ON_InstanceDefinition::Empty

  • ON_Linetype::Unset
  • ON_Linetype::Continuous
  • ON_Linetype::ByLayer
  • ON_Linetype::ByParent

  • ON_Layer::Unset
  • ON_Layer::Default

  • ON_TextStyle::Unset
  • ON_TextStyle::Default
  • ON_TextStyle::ByLayer
  • ON_TextStyle::ByParent

  • ON_DimStyle::Unset
  • ON_DimStyle::Default
  • ON_DimStyle::DefaultInchDecimal
  • ON_DimStyle::DefaultInchFractional
  • ON_DimStyle::DefaultFootInchArchitecture
  • ON_DimStyle::DefaultMillimeterSmall
  • ON_DimStyle::DefaultMillimeterLarge
Public propertyLeaderArrowBlockId
Public propertyLeaderArrowLength
Public propertyLeaderArrowType
Public propertyLeaderContentAngleType
Style of leader content angle Horizontal Aligned Rotated
Public propertyLeaderCurveType
Public propertyLeaderHasLanding
Public propertyLeaderLandingLength
Public propertyLeaderTextHorizontalAlignment
Public propertyLeaderTextOrientation
Public propertyLeaderTextRotationDegrees
Public propertyLeaderTextRotationRadians
Angle of leader text for Rotated style
Public propertyLeaderTextVerticalAlignment
Public propertyLengthFactor
Public propertyLengthResolution
Public propertyMaskColor
Public propertyMaskColorSource
Public propertyMaskFrameType
Public propertyMaskOffset
Public propertyParentId
Get or Set the Id of this DimensionStyle's parent. If ParentId is Guid.Empty, this DimensionStyle has no parent
Public propertyPrefix
Public propertyRoundoff
Public propertyScaleLeftLengthMillimeters
Public propertyScaleRightLengthMillimeters
Public propertyStackFractionFormat
Public propertyStackHeightScale
Public propertySuffix
Public propertySuppressArrow1
Public propertySuppressArrow2
Public propertySuppressExtension1
Public propertySuppressExtension2
Public propertyTextGap
Public propertyTextHeight
Public propertyTextHorizontalAlignment
Public propertyTextMoveLeader
Public propertyTextOrientation
Public propertyTextRotation
Public propertyTextUnderlined
Public propertyTextVerticalAlignment
Public propertyToleranceFormat
Public propertyToleranceHeightScale
Public propertyToleranceLowerValue
Public propertyToleranceResolution
Public propertyToleranceUpperValue
Public propertyToleranceZeroSuppress
Public propertyUserStringCount
Gets the amount of user strings.
Public propertyZeroSuppress
Top
See Also