Click or drag to resize

Interop Methods

The Interop type exposes the following members.

Methods
  NameDescription
Public methodStatic memberCommandLineOptionFromNativePointer
Create a command line option for a native pointer. Do not hold onto this class as it does not control the lifetime of the underlying pointer
Public methodStatic memberCreateFromNativePointer
Constructs a RhinoCommon Geometry class from a given ON_Geomety*. The ON_Geometry* must be declared on the heap and its lifetime becomes controlled by RhinoCommon.
Public methodStatic memberFileReadOptionsConstPointer
Returns the underlying const CRhinoFileReadOptions* for a Rhino.FileIO.FileReadOptions object. You should only be interested in using this function if you are writing C++ code.
Public methodStatic memberFileWriteOptionsConstPointer
Returns the underlying const CRhinoFileWriteOptions* for a Rhino.FileIO.FileWriteOptions object. You should only be interested in using this function if you are writing C++ code.
Public methodStatic memberFontFromPointer
Create managed Font from native ON_Font*
Public methodStatic memberFromOnBrep
Copies a Rhino_DotNet brep to a RhinoCommon brep class.
Public methodStatic memberFromOnCurve
Copies a Rhino_DotNet curve to a RhinoCommon curve class.
Public methodStatic memberFromOnMesh
Copies a Rhino_DotNet mesh to a RhinoCommon mesh class.
Public methodStatic memberFromOnSurface
Copies a Rhino_DotNet surface to a RhinoCommon Surface class.
Public methodStatic memberNativeGeometryConstPointer
Returns the underlying const ON_Geometry* for a RhinoCommon class. You should only be interested in using this function if you are writing C++ code.
Public methodStatic memberNativeGeometryNonConstPointer
Returns the underlying non-const ON_Geometry* for a RhinoCommon class. You should only be interested in using this function if you are writing C++ code.
Public methodStatic memberNativeNonConstPointer(DisplayPipeline)
Get CRhinoDisplayPipeline* for a DisplayPipeline instance
Public methodStatic memberNativeNonConstPointer(GetPoint)
Get CRhinoGetPoint* from a GetPoint instance
Public methodStatic memberNativeNonConstPointer(RhinoViewport)
Get CRhinoViewport* from a RhinoViewport instance
Public methodStatic memberNativeNonConstPointer(ViewCaptureSettings)
Get a CRhinoPrintInfo* for a given ViewCaptureSettings class
Public methodStatic memberNativeNonConstPointer(ViewportInfo)
Get ON_Viewport* from a ViewportInfo instance
Public methodStatic memberNativeRhinoDocPointer
Gets the C++ CRhinoDoc* for a given RhinoCommon RhinoDoc class.
Public methodStatic memberNSFontFromFont(Font)
Get native NSFont* from a Rhino Font. Only works on Mac
Public methodStatic memberNSFontFromFont(Font, Double)
Get native NSFont* from a Rhino Font. Only works on Mac
Public methodStatic memberPlugInPointer
Gets a C++ plug-in pointer for a given RhinoCommon plug-in.

This is a Rhino SDK function.

Public methodStatic memberRhinoObjectConstPointer
Returns the underlying const CRhinoObject* for a RhinoCommon class. You should only be interested in using this function if you are writing C++ code.
Public methodStatic memberRhinoObjectFromPointer
Constructs a RhinoCommon Rhino object from an unmanaged C++ RhinoObject pointer.
Public methodStatic memberToIRhinoViewport
Convert a Rhino.Display.Viewport to an RMA.Rhino.IRhinoViewport.
Public methodStatic memberToOnBrep
Constructs a Rhino_DotNet OnBrep that is a copy of a given brep.
Public methodStatic memberToOnCurve
Constructs a Rhino_DotNet OnCurve that is a copy of a given curve.
Public methodStatic memberToOnMesh
Constructs a Rhino_DotNet OnMesh that is a copy of a given mesh.
Public methodStatic memberToOnSurface
Constructs a Rhino_DotNet OnSurface that is a copy of a given curve.
Public methodStatic memberToOnXform
Constructs a Rhino_DotNet OnXform from a given RhinoCommon Transform.
Public methodStatic memberTryCopyFromOnArc
Attempts to copy the contents of a RMA.OpenNURBS.OnArc to a Rhino.Geometry.Arc.
Public methodStatic memberTryCopyToOnArc
Attempts to copy the contents of a Rhino.Geometry.Arc to a RMA.OpenNURBS.OnArc.
Public methodStatic memberViewCaptureFromPointer
Create a ViewCaptureSettings class from a native const CRhinoPrintInfo* The pointer values are copied
Top
See Also