FileImportPlugIn Methods |
The FileImportPlugIn type exposes the following members.
Name | Description | |
---|---|---|
AddFileTypes | ||
CreateCommands |
Called right after plug-in is created and is responsible for creating
all of the commands in a given plug-in. The base class implementation
Constructs an instance of every publicly exported command class in your
GetLicense(LicenseBuildType, ValidateProductKeyDelegate, OnLeaseChangedDelegate) |
Verifies that there is a valid product license for your plug-in, using
the Rhino licensing system. If the plug-in is installed as a standalone
node, the locally installed license will be validated. If the plug-in
is installed as a network node, a loaner license will be requested by
the system's assigned Zoo server. If the Zoo server finds and returns
a license, then this license will be validated. If no license is found,
then the user will be prompted to provide a license key, which will be
GetLicense(LicenseCapabilities, String, ValidateProductKeyDelegate, OnLeaseChangedDelegate) |
Verifies that there is a valid product license for your plug-in, using
the Rhino licensing system. If the plug-in is installed as a standalone
node, the locally installed license will be validated. If the plug-in
is installed as a network node, a loaner license will be requested by
the system's assigned Zoo server. If the Zoo server finds and returns
a license, then this license will be validated. If no license is found,
then the user will be prompted to provide a license key, which will be
GetLicenseOwner |
Get the customer name and organization used when entering the product
IsTextureSupported |
Returns true if this renderer can render the texture natively without needing it to be baked into a bitmap, false otherwise.
MakeReferenceTableName | ||
ObjectPropertiesPages(ObjectPropertiesPageCollection) |
Override this function is you want to extend the object properties dialog.
This method will be called each time a new document is created for each
instance of a object properties panel. On Windows there will be a single
panel per document but on Mac there may be many properties panel per
OptionsDialogPages |
Override this function if you want to extend the options dialog. This function is
ReadDocument |
Called whenever a Rhino document is being loaded and plug-in user data was
ReadFile | ||
ReturnLicense |
Returns, or releases, a product license that was obtained from the Rhino
licensing system. Note, most plug-ins do not need to call this as the
SaveSettings |
Write settings to disk which will raise a SettingsSaved
ShouldCallWriteDocument |
Called whenever a Rhino is about to save a .3dm file.
If you want to save plug-in document data when a model is
saved in a version 5 .3dm file, then you must override this
WriteDocument |
Called when Rhino is saving a .3dm file to allow the plug-in