Click or drag to resize

MeshNgon Methods

The MeshNgon type exposes the following members.

Methods
  NameDescription
Public methodBoundaryVertexIndexList
Get the outer boundary mesh vertex list of the ngon.

Vertices are sorted counterclockwise with respect to the direction of the face, although the degree by which vertex normals will respect this might vary.

Public methodCompareTo
Compares this MeshNgon with otherNgon and returns a value of 1, 0, or -1.

Priority is for vertex count, then face count, then vertex index list values, then face index list values.

Public methodStatic memberCreate
Constructs an ngon from lists of mesh vertex and face indexes.
Public methodEquals(MeshNgon)
Determines if this ngon and otherNgon are identical.
Public methodEquals(Object)
Determines if otherObj is a MeshNgon and is identical to this ngon.
(Overrides ObjectEquals(Object).)
Public methodFaceIndexList
Get the ngon's mesh face index list.
Public methodGetHashCode
Returns a runtime-stable hash code for the current mesh ngon. You are not allowed to rely on persistence of this hash code in serialization, but for each instance of the application, this hash code will be the same for ngons with identical vertex and face lists.
(Overrides ObjectGetHashCode.)
Public methodSet
Set the ngon vertex and face index lists.
Public methodToString
Returns a string representation for this MeshNgon. This is to provide a meaningful visualization of this structure and is subject to change in newer releases.
(Overrides ObjectToString.)
Top
See Also