Click or drag to resize

BrepRegion Methods

The BrepRegion type exposes the following members.

Methods
  NameDescription
Public methodBoundaryBrep
Gets the boundary of a region as a brep object. If the region is finite, the boundary will be a closed manifold brep. The boundary may have more than one connected component.
Protected methodDispose(Boolean)
For derived class implementers.

This method is called with argument true when class user calls Dispose(), while with argument false when the Garbage Collector invokes the finalizer, or Finalize() method.

You must reclaim all used unmanaged resources in both cases, and can use this chance to call Dispose on disposable fields if the argument is true.

Also, you must call the base virtual method within your overriding method.
Public methodGetFaceSides
Gets an array of BrepRegionFaceSide entities delimiting this region.
Protected methodNonConstOperation
Top
See Also