Click or drag to resize

ViewTable Methods

The ViewTable type exposes the following members.

Methods
  NameDescription
Public methodAdd
Constructs a new Rhino view and, at the same time, adds it to the list.
Public methodAddPageView(String)
Constructs a new page view with a given title and, at the same time, adds it to the list.
Public methodCode exampleAddPageView(String, Double, Double)
Constructs a new page view with a given title and size and, at the same time, adds it to the list.
Public methodDefaultViewLayout
Public methodEnableCameraIcon
Use to turn camera icon on and off
Public methodEnableRedraw
Enables or disables screen redrawing.
Public methodFind(Guid)
Finds a view in this document with a given main viewport Id.
Public methodFind(String, Boolean)
Finds a view in this document with a main viewport that has a given name. Note that there may be multiple views in this document that have the same name. This function only returns the first view found. If you want to find all the views with a given name, use the GetViewList function and iterate through the views.
Public methodFlashObjects
Cause objects selection state to change momentarily so the object appears to flash on the screen.
Public methodFourViewLayout
Public methodGetEnumerator
Public methodCode exampleGetPageViews
Gets all page views in the document.
Public methodGetStandardRhinoViews
Public methodGetViewList(ViewTypeFilter)
Gets an array of all the views.
Public methodGetViewList(Boolean, Boolean) Obsolete.
Gets an array of all the views.
Public methodIsCameraIconVisible
Determine if a camera icon is being shown
Public methodCode exampleRedraw
Redraws all views.
Public methodThreeViewLayout
Top
See Also