Click or drag to resize

CommandAliasList Methods

The CommandAliasList type exposes the following members.

Methods
  NameDescription
Public methodStatic memberAdd
Adds a new command alias to Rhino.
Public methodStatic memberClear
Removes all aliases from the list.
Public methodStatic memberDelete
Deletes an existing command alias from Rhino.
Public methodStatic memberGetDefaults
Constructs a dictionary containing as keys the default names and as value the default macro.

The returned dictionary contains a copy of the settings.

Public methodStatic memberGetMacro
Returns the macro of a command alias.
Public methodStatic memberGetNames
Returns a list of command alias names.
Public methodStatic memberIsAlias
Verifies that a command alias exists in Rhino.
Public methodStatic memberIsDefault
Computes a value indicating if the current alias list is the same as the default alias list.
Public methodStatic memberSetMacro
Modifies the macro of a command alias.
Public methodStatic memberToDictionary
Constructs a new dictionary that contains: as keys all names and as values all macros.

Modifications to this dictionary do not affect any Rhino command alias.

Top
See Also